Технические темы
1 1 1 1 1 1 1 1 1 1 Рейтинг 4.00 (1 Голос)

 Сетевое планирование

Сетевой план состоит из элементарных работ или «звеньев» и событий, соответствующих определенному состоянию исследуемого объекта. При этом должна соблюдаться определенная последовательность событий, согласно которой одни работы не могут начаты раньше, чем закончатся другие. В качестве основных показателей при разработке сетевых графиков принимаются время, ресурсы, стоимостные показатели и т. д. В дальнейшем в качестве основного критерия будет рассматриваться время как наиболее важный критерий, характеризующий динамическую модель.

Графическое изображение комплекса работ называется сетевым графиком. Существует два вида сетевых графиков. Первый предусматривает, что работа (aij ) - это дуга, а событие (Аi ) - вершина (рис.15). В другом случае наоборот: работа - вершина, событие - дуга В экономике наибольшее распространение получил первый вид. При этом считается, что событие не является процессом, не требует затрат труда и ресурсов, наступает практически мгновенно. Различают три вида событии: исходное (Ai ), промежуточное (А2 – А5) и завершающее (А6). Исходное событие в математике именуют, как Исток, а завершающее -Сток. Если планируемый процесс имеет несколько целей, то сетевой график имеет несколько стоков (завершающих событий).

При составлении сетевого графика используют три основных понятия: работа, событие, путь. Работа представляет собой некоторую часть планируемого экономического комплекса операций. Она выражается на графике в виде:

Рис.3.1

- действительной работы, т. е. трудового процесса или действия, требующего затрат времени, труда, средств и ресурсов;

- пассивной работы, не требующей затрат труда и ресурсов, но для своего окончания требующей определенного времени (например, отвердение бетона при строительстве);

- фиктивной работы, не требующей затрат времени, труда и расхода ресурсов, но выполняющей роль связки, указывающей на то, что какая-то работа не может быть начата, пока не окончена другая (показана пунктиром на рис. 3.1);

Путь - это любая непрерывная последовательность работ сетевого графика. Различают следующие пути: полный, предшествующий и последующий.

Полный путь (Lk) - последовательность работ от истока до стока. Длина полного пути представляет собой сумму продолжительностей составляющих его работ: . Критический путь (Lкр) - наиболее продолжительный из всех полных путей. В сетевых моделях критический путь обязательно существует, но не всегда единственный.

Понятие критического пути является важнейшим в теории сетевого планирования, т. к. определяет завершение планируемого комплекса работ. Для сокращения сроков всего комплекса необходимо прежде всего принять меры в сокращению сроков выполнения работ, находящихся на критическом пути.

Предшествующий путь - последовательность работ от истока до рассматриваемого события. Последующий путь - последовательность работ от рассматриваемого события до завершающего события (стока).

Расчет сетевого графика подразумевает определение временных параметров: продолжительности критического пути, наиболее раннее и наиболее позднего из допустимых времен наступления события и все резервы работ. Различают соответственно время раннего и позднего начала события, время раннего и позднего его окончания.

Алгоритм расчета сетевого графика следующий:

1. Определяется время раннего начала работ, как максимальное время, необходимое для завершения всех предшествующих работ:

(3.1)

2. Определяется время раннего окончания работы, как сумма времени ее раннего начала и продолжит ельности самой работы:

(3.2)

3. Определяется длина критического пути, как максимальное значение из всех возможных ранних окончаний:

(3.3)

4. Определяется время позднего окончания работы, как разница между длиной критического пути и минимальным по продолжительности из всех возможных последующих путей:

(3.4)

5. Определяется время позднего начала работы, как разность между поздним ее окончанием и временем выполнения самой работы:

(3.5)

6. Подсчитываются полные резервы работ, как разность между поздним началом и ранним началом или поздним окончанием и поздним началом:

(3.6)

Отсюда следует, что время раннего начала работы есть максимальное из ранних окончаний всех предшествующих работ. Одновременно время позднего окончания есть минимальное из всех поздних начал последующих работ.

Для того чтобы разорвать этот замкнутый круг, используют фиксированные точки. У истока начинается ось времени, т. е. ранние начала работ, начинающиеся в истоке, равны нулю. Вся экономическая операция заканчивается в стоке по достижению критического времени, т. е. поздние окончания работ, заканчивающиеся в стоке, равны tкp. Отсюда разрешимость сетевой задачи лежит в последовательном пересчете по ссылке на предшествующие или последующие работы.

Если расчет сетевого графика представить как выполнение операции поиска и выбора данных по некоторому критерию, то можно воспользоваться рядом функций Excel по управлению базами данных. В качестве критерия будет выступать поле фиксированного времени. При определении раннего начала работ в поле раннего окончания следует указать критерий отбора, соответствующий такому событию, как окончание предшествующих работ. При определении времени позднего окончания в поле позднего начала следует использовать критерий начала последующих работ.

Для того чтобы разобраться в методике расчета сетевого графика с использованием функций по управлению базами данных, следует обратиться к конкретному примеру производственной деятельности.

Задача сетевой план  разборки дизеля

Пример

Для выполнения частичной разборки дизеля СМД-62 следует выполнить комплекс работ. Мастер участка на основании норм времени оценил продолжительность выполнения работ (табл.3.1) и последовательность их выполнения (рис.3.2).

Таблица 3.1 Продолжительность работ

Наименование работы

№ работы

Время (мин)

Снятие сильфонных трубок и патрубков

1-2

12

Снятие кронштейнов выхлопной трубы и воздухоочистителя

1-3

7

Снятие турбокомпрессора

2-3

8

Снятие топливопроводов низкого давления и фильтров

2-4

12

Снятие трубок водяного насоса и компрессора

2-5

14

Снятие топливопроводов высокого давления и трубок слива

3-4

18

Снятие муфты сцепления

4-5

18

Снятие топливного насоса

4-6

10

Снятие водяного насоса и компрессора

5-6

10

Рис.3.2

Необходимо составить сетевой план и определить: максимальную продолжительность выполнения работ (критический путь) и полные резервы работ.

Решение.

Вносим исходные данные на рабочий Лист Excel с таким расчетом, чтобы критерии отбора располагались в верхней части таблицы (табл.3.2).

Начнем с поиска раннего времени наступления событий, для чего:

- время раннего начала (Тр. н.) для работ, начинающихся в истоке сети, равное нулю;

- в колонку ранних окончаний записываем сумму Т р. н. и времени выполнения работы;

- для свободных ячеек времени раннего начала воспользуемся функцией управления базой данных ДМАКС(база данных, поле, критерий). В качестве базы данных следует указать область А5:F14 (в таблице 3.2 выделена темным цветом). Поле, по которому осуществляется отбор, - поле времени раннего окончания (ячейка F5). Критерий отбора – событие, соответствующее окончанию предшествующих работ (например, для работы «3-4» (топливопроводы высокого давления) – это Конец:3). Для каждой работы формула будет содержать свой критерий. Например, для снятия топливопроводов низкого давления и фильтров время раннего начала можно определить как наибольший по продолжительности путь из всех предшествующих, т. е. =ДМАКС(А5:F14, F5, А2:А3). Снятие топливопроводов низкого давления и фильтров начинается в п.2, поэтому в качестве критерия выбрано - Конец:2 (ячейки А2:А3).

Таблица 3.2

 

A

B

C

D

E

F

G

H

I

J

1

     

Критерии выбора

       

2

Конец

Конец

Конец

Конец

 

Начало

Начало

Начало

Начало

 

3

2

3

4

5

 

2

3

4

5

 

4

     

Параметры сетевого графика

       

5

Наим. работы

Начало

Конец

Время

Тр. н.

Тр. о.

Тп. н.

Тп. о.

Резерв

Кр. путь

6

Компенсаторы

1

2

12

0

"=СУММ(D6:E6)"

       

7

Кронштейны

1

3

7

0

"=СУММ(D7:E7)"

       

8

Турбокомпре-ссор

2

3

8

 

"=СУММ(D8:E8)"

       

9

Топливопр. НД и фильтры

2

4

12

 

"=СУММ(D9:E9)"

       

10

Трубки вод. насоса и компр.

2

5

14

 

"=СУММ(D10:E10)"

       

11

Топливопр. ВД и трубки слива

3

4

18

 

"=СУММ(D11:E11)"

       

12

Муфта сцепления

4

5

18

 

"=СУММ(D12:E12)"

       

13

Топл. насос

4

6

10

 

"=СУММ(D13:E13)"

       

14

Вод. насос и компрессор

5

6

10

 

"=СУММ(D14:E14)"

       

15

   

Т критического пути

"=МАКС(F6:F14)"

       

Максимальная величина среди всех ранних окончаний является продолжительностью критического пути. Поэтому в ячейку F15 запишем формулу определения максимального значения среди всех ранних окончаний: =МАКС(F6:F14).

Далее определим поздние сроки начала и окончания работ. Расчет выполняем в обратную сторону, то есть от времени критического пути:

- записываем критическое время для работ, оканчивающихся в стоке. Так для ячеек Н13 и Н14 проставляется формула: =F15 (табл. 3.3);

- колонку поздних начал (Тп. н.) записываем разность между временем позднего оконча­ния и продолжительностью самой работы;

- для свободных ячеек времени раннего начала воспользуемся функцией управления базой данных: ДМИН(база данных, поле, критерии). База данных расширится и охватит все адресное пространство (А5:Н14). Поле, по которому будет осуществляться отбор, соответствует полю времени позднего начала выполнения работ (G5). В качестве критерия выбирается событие, соответствующее начало всех последующих работ. Например, для работ по снятию топливопроводов низкого давления: =ДМИН(А5:Н14;G5;Н2:Н3). Снятие топливопроводов низкого давления оканчивается в п.4, поэтому нас интересуют все последующие работы, начинающиеся в п.4 (критерий - Начало:4).

Таблица 3.3

 

A

B

C

D

E

F

G

H

I

J

1

     

Критерии выбора

     

2

Конец

Конец

Конец

Конец

 

Начало

Начало

Начало

Начало

 

3

2

3

4

5

 

2

3

4

5

 

4

     

Параметры сетевого графика

     

5

Наим. работы

Начало

Конец

Время

Тр. н.

Тр. о.

Тп. н.

Тп. о.

Резерв

Кр. путь

6

Компенсаторы

1

2

12

0

12

"=H6-D6"

     

7

Кронштейны

1

3

7

0

7

"=H7-D7"

     

8

Турбокомпре-ссор

2

3

8

12

20

"=H8-D8"

     

9

Топливопр. НД и фильтры

2

4

12

12

24

"=H9-D9"

     

10

Трубки вод. насоса и компр.

2

5

14

12

26

"=H10-D10"

     

11

Топливопр. ВД и трубки слива

3

4

18

20

38

"=H11-D11"

     

12

Муфта сцепления

4

5

18

38

56

"=H12-D12"

     

13

Топл. насос

4

6

10

38

48

"=H13-D13"

"=F15"

   

14

Вод. насос и компрессор

5

6

10

56

66

"=H14-D14"

"=F15"

   

15

   

Т критического пути

66

       

Теперь можно перейти к определению полных резервов работ. Для этого в колонку Резерв записываем формулу, соответствующую разности между поздним и ранним окончанием выполнения работ. Колонку критического пути наполняем формулой =ЕСЛИ(ячейка_со_значением_резерва=0,"Кр. пугь";"---").

Результаты решения (таблица 3.4).

Согласно проведенному расчету общая продолжительность работ составит 66 минут. Существует только один критический путь: Снятие компенсаторов => Турбокомпрессор=> Топливопроводы ВД => Муфта сцепления => Водяной насос и компрессор. При этом существует большой резерв времени в снятии трубок водяного насоса и компрессора (30 мин). Наличие большого резерва свидетельствует о возможности сокращения критического пути за счет перераспределения средств. Рис.3.3 наглядно демонстрирует график выполнения работ.

Таблица 3.4

Наим. работы

Нач.

Кон.

Время

Тр. н.

Тр. о.

Тп. н.

Тп. о.

Резерв

Кр. путь

Компенсаторы

1

2

12

0

12

0

12

0

Кр. путь

Кронштейны

1

3

7

0

7

13

20

13

------------

Турбокомпре-ссор

2

3

8

12

20

12

20

0

Кр. путь

Топливопр. НД и фильтры

2

4

12

12

24

26

38

14

------------

Трубки вод. насоса и компр.

2

5

14

12

26

42

56

30

------------

Топливопр. ВД и трубки слива

3

4

18

20

38

20

38

0

Кр. путь

Муфта сцепления

4

5

18

38

56

38

56

0

Кр. путь

Топл. насос

4

6

10

38

48

56

66

18

------------

Вод. насос и компрессор

5

6

10

56

66

56

66

0

Кр. путь

   

Т критического пути

66

       

Рис.3.3

Такое предположение о перераспределении требует обоснования, т. е. оптимизационных расчетов.

Задача по сетевому планированию - 4.0 out of 5 based on 1 vote

Добавить комментарий


Защитный код
Обновить

Google